EtherChannel の概要と基本設定 – Cisco スイッチ

ネットワーク技術解説

2020/6/12 更新

通信機器同士を接続する場合、通常1本のネットワークLANケーブルを使用します。複数本を同時に利用することはできませんが、リンクアグリゲーションの技術により複数本の物理リンクを同時に使用可能にします。リンクアグリゲーションを実現するためのCisco独自のプロトコルとしてEtherChannelがあります。

Cisco EtherChannel の概要

EtherChannel(イーサチャネル)は複数の物理リンクを1つの論理リンクとして束ねる技術です。EtherChannel は Cisco 独自の呼び方で一般的な技術としてはリンクアグリゲーションと呼ばれます。

Cisco スイッチ 2本の 論理的リンク EtherChannel
2本の物理リンクを1つの論理リンク(EtherChannel)に束ねたイメージ図

論理リンクに束ねられる物理リンクをメンバーポートと呼び、最大8つの物理リンクをメンバーポートとして設定できます。論理リンクの帯域幅は物理リンクを束ねた合計になります。

EtherChannel プロトコルの種類

EtherChannel プロトコル

EtherChannel のプロトコルを使用してリンクの両端のポート間でネゴシエーションを行い自動的に設定する方法と、固定で設定する方法があります。

また、プロトコルは以下の2種類があります。

  • PAgP(Port Aggregation Control Protocol)
  • LACP(Link Aggregation Control Protocol)

PAgPはCisco独自のプロトコルで、LACPはIEEE 802.3ad で定義されたプロトコルです。リンクの両側で同じプロトコルを指定する必要があります。

PAgP と LACP プロトコルのモード

それぞれのプロトコルでは、相手に対し積極的にEtherChannelになるようネゴシエーションを開始するモードとネゴシエーションされて初めてネゴシエーションを開始する受け身のモードの2種類があります。

Cisco スイッチ EtherChannel プロトコルのモードコマンド

お互いのポートは以下の組み合わせの場合にだけEtherChannelが形成されます。

Cisco スイッチ リンクアグリゲーション ネゴシエーション可能なモードの組み合わせ
EtherChannelネゴシエーション可能なモードの組み合わせ

EtherChannel の PAgP 設定例

PAgP設定例の概要

参考に Cisco 独自のプロトコルPAgPを設定してみます。モードは desirable と auto の組み合わせで設定します。

この場合、desirable側から積極的にEtherChannelになるよう相手にネゴシエーションをおこないauto側ではネゴシエーションを受けて双方でEtherChannelが形成されます。

構成はSwitchAとBの2つを用意して、ポート2つ(Gi1/0/1 と1/0/2)をメンバーポートにした EtherChannel ポート(Port-channel 1) を作成します。

EtherChannel PAgP によるスイッチ間の desirable/auto 接続図

物理インターフェイスの設定

物理インターフェイスのEtherChannel 設定

SwitchA# configure terminal
SwitchA(config)# interface range GigabitEthernet 1/0/1 – 2
SwitchA(config-if-range)# channel-protocol pagp
SwitchA(config-if)# channel-group 1 mode ?
active Enable LACP unconditionally
auto Enable PAgP only if a PAgP device is detected
desirable Enable PAgP unconditionally
on Enable Etherchannel only
passive Enable LACP only if a LACP device is detected
SwitchA(config-if-range)# channel-group 1 mode desirable
Creating a port-channel interface Port-channel 1
SwitchA(config-if-range)# end
SwitchA#

論理インターフェイス Port-channel の設定

EtherChannelにVLANの割り当て設定が必要な場合は、物理インターフェイスにEtherChannelの設定をした時に自動で作成された Port-channel 1 の論理インターフェイスへ設定します。

以下では VLAN2を「Port-channel 1」へ設定しています。

SwitchA#configure terminal
SwitchA(config)#interface Port-channel 1
SwitchA(config-if)#switchport mode access
SwitchA(config-if)#switchport access vlan 2

相手側機器への設定

もう片方のSwitchBの設定も同じように設定します。SwitchBではモードに “auto” を設定します。

SwitchB#configure terminal
SwitchB(config)#interface range GigabitEthernet 1/0/1 – 2
SwitchB(config-if-range)#channel-protocol pagp
SwitchB(config-if-range)#channel-group 1 mode auto
Creating a port-channel interface Port-channel 1
SwitchB(config-if-range)#end
SwitchB#
SwitchB#configure terminal
SwitchB(config)#interface Port-channel 1
SwitchB(config-if)#switchport mode access
SwitchB(config-if)#switchport access vlan 2

EtherChannel 設定の確認

SwitchA側の設定を確認

SwitchA# show running-config
~~~
!
interface Port-channel1
switchport access vlan 2
switchport mode access
!
interface GigabitEthernet1/0/1
switchport access vlan 2
switchport mode access
channel-group 1 mode desirable
!
interface GigabitEthernet1/0/2
switchport access vlan 2
switchport mode access
channel-group 1 mode desirable

SwitchB側の設定を確認

SwitchB# show running-config
~~~
!
interface Port-channel1
switchport access vlan 2
switchport mode access
!
interface GigabitEthernet1/0/1
switchport access vlan 2
switchport mode access
channel-protocol pagp
channel-group 1 mode auto
!
interface GigabitEthernet1/0/2
switchport access vlan 2
switchport mode access
channel-protocol pagp
channel-group 1 mode auto
!

EtherChannelポートのステータス確認

設定が完了したらLANケーブルを接続して、EtherChannelのステータスが問題ないか確認します。

EtherChannel 設定ステータス確認コマンド

「show etherchannel」では、設定したグループで使用しているプロトコルなどを確認できます。

SwitchB#show etherchannel
Channel-group listing:
——————————–
Group: 1
———————-
Group state = L2
Ports: 2 Maxports = 8
Port-channels: 1 Max Port-channels = 1
Protocol: PAgP
Minimum Links: 0

「show etherchannel summary」では論理ポートとそれに含まれる物理ポートのステータスが確認できます。

SwitchB#show etherchannel summary
Flags: D – down P – bundled in port-channel
I – stand-alone s – suspended
H – Hot-standby (LACP only)
R – Layer3 S – Layer2
U – in use f – failed to allocate aggregator
M – not in use, minimum links not met
u – unsuitable for bundling
w – waiting to be aggregated
d – default port
Number of channel-groups in use: 1
Number of aggregators: 1
Group Port-channel Protocol Ports
——+————-+———–+———————————————–
1 Po1(SU) PAgP Gi1/0/1(P) Gi1/0/2(P)

「show interfaces Port-channel group_number 」では、EtherChannelの論理ポートが up していることや、メンバーポートになる物理ポートが確認できます。

SwitchB#show interfaces Port-channel 1
Port-channel1 is up, line protocol is up (connected)
Hardware is EtherChannel, address is 001e.4a3a.2982 (bia 001e.4a3a.2982)
MTU 1500 bytes, BW 2000000 Kbit, DLY 10 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA, loopback not set
Keepalive set (10 sec)
Full-duplex, 1000Mb/s, link type is auto, media type is unknown
input flow-control is off, output flow-control is unsupported
Members in this channel: Gi1/0/1 Gi1/0/2
~ ~ ~

参考リンク

リンクアグリゲーション 「LAG」を使った冗長化の概要とメリット

トランクポートの概要と設定 – Cisco スイッチ


コメント