ゲートウェイを冗長化する Cisco HSRP の基本設定と確認方法

ネットワーク機器、操作・設定

HSRP(Hot Standby Router Protocol) は Cisco 独自のデフォルトゲートウェイの仮想IPを冗長化するためのプロトコルです。CiscoのルーターやスイッチにHSRPを設定することにより、機器の障害によるゲートウェイの停止に備え自動でもう一方の機器に切り替わるように準備しておくことが可能です。

Cisco HSRP 設定の概要

ゲートウェイを冗長化するためにCiscoのHSRPはL3スイッチの SVI やルーテッドポート、およびルーターのインターフェイスに設定することができます。
以下は、HSRP を利用するためにインターフェイスに必要な基本設定です。

  • IP アドレス
  • HSRP グループ番号
  • 仮想 IP アドレス
  • プライオリティ値

これらのHSRPに必要な設定は冗長化するCiscoの機器すべてに対しておこなう必要があります。HSRPの設定では物理IPアドレスとは別にゲートウェイのIPアドレスを仮想IPアドレスとして複数の機器で共有することで冗長化します。

HSRP の各デフォルト値は以下のようになっています。

Cisco HSRP  各デフォルト値

Cisco HSRP の基本設定

ここでは、サンプル設定として Cisco Catalyst 3750 スイッチを使用してHSRPを設定しています。以下はサンプル構成です。SwtichAとBでHSRPを設定しPCから見たデフォルトゲートウェイを冗長化する設定をおこないます。

① IP アドレスの設定

Cisco HSRP - コマンド IPアドレスの設定

CiscoのSwitchAとSwitchB の SVI インターフェイス(ここでは VLAN 1を使用)へ IP アドレスを設定します。インターフェイスがシャットダウンされている場合は no shutdown コマンドを実行します。

Cisco コマンド実行例:

switchA

switchA# configure terminal
switchA(config)# interface vlan 1
switchA(config-if)# ip address 192.168.1.2 255.255.255.0
switchA(config-if)# no shutdown

switchB

switchB# configure terminal
switchB(config)# interface vlan 1
switchB(config-if)# ip address 192.168.1.3 255.255.255.0
switchB(config-if)# no shutdown

② HSRP グループ番号と仮想 IP アドレスの設定

同じインターフェイスに ゲートウェイ(HSRP)の設定を行っていきます。IPアドレスはほかのデバイスから見てゲートウェイ(またはデフォルトゲートウェイ)となる仮想IPアドレスを両方の機器で設定します。

Cisco HSRP - コマンド 仮想IPアドレスの設定

Cisco コマンド実行例:

switchA

switchA(config-if)# standby 1 ip 192.168.1.4

swtichB

switchB(config-if)# standby 1 ip 192.168.1.4

③ HSRP プライオリティの設定

HSRPの仮想IPアドレスを共有している機器の中でどの機器がアクティブなゲートウェイになるかを決定するための基準となるプライオリティの設定をします。より高い値をもつ方がゲートウェイとなります。

Cisco HSRP - コマンド プライオリティの設定

Cisco コマンド実行例:

switchA

switchA(config-if)# standby 1 priority 110

switchB

switchB(config-if)# standby 1 priority 105

Cisco HSRP の設定とステータス確認

Cisco HSRP - HSRP設定確認コマンド ステータス確認

HSRPの設定確認のコマンド。 アクティブ(Active)/スタンバイ(Standby) のステータスのほかにも、 仮想IPアドレス、仮想MACアドレスの情報などが確認できます。

Cisco コマンド実行例:

switchA

コマンド ステータス確認結果 switchA

switchB

コマンド ステータス確認結果 switchB

Cisco HSRP のオプション設定

① プリエンプト(preempt)設定

現在のアクティブルーターより自身のプライオリティが高い場合、機能を引き継いで自身がアクティブルーターになることを許可したいルーターにはこの設定が必要です。

Cisco HSRP - コマンド プリエンプトの設定

コマンド実行例:

switchA

switchA(config-if)# standby 1 preempt

switchB

switchB(config-if)# standby 1 preempt

② トラック設定(track)設定

HSRPのオプション設定として、指定したインターフェイスを追跡(track)することができます。追跡しているインターフェイスがダウンしたことをトリガーに、プライオリティ値を下げることができます。

Cisco HSRP のリンクダウン後の切り替わり図
Cisco HSRP - コマンド トラックの設定

コマンド実行例:

switchA(config-if)# standby 1 track gigabitEthernet 1/0/2

この設定を追加することにより、sutichA の インターフェイス Gi1/0/2 がダウンした場合、自身のプライオリティ値をデフォルトの 10 下げます。その結果、switchA はプライオリティが100 になり、現在の switchBが105 に設定してあるので、switchB の方がプライオリティが高くなります。

この状態で、switchB がアクティブルーターになるためには、プリエンプト(preempt)の設定が事前に必要です。

以下は、アクティブルーターが switchB へ切り替わった場合のHSRPステータスの例です。

switchA

Cisco HSRP 設定 - コマンド トラックの設定確認結果 switchA

switchB

Cisco HSRP 設定 - コマンド トラックの設定確認結果 switchB

参考リンク

HSRP(Hot Standby Router Protocol)とは – 基本動作の仕組み

ネットワークのゲートウェイとは – Gateway の種類と役割

ルーターとは – 概要と基本動作


コメント